Hitfilm keeps randomly force closing

Hi everyone. Hitfilm has been dependable for the past year, but now when I add media, it tends to force close and most of the time not recover what I was working on. Does anyone know what's wrong? It is really frustrating having to edit knowing it will close sooner or later.

Comments

  • Hm, what has changed on your system or workflow? Are you using clips in a different format than previously? (What format are they?) Are they being stored in a different location? Are your GPU drivers up to date? Have you installed an update to your OS, or any other modifications to your system?
  • Hi Axel. There are two changes I have made to my system. We replaced the graphics card to the HD Radeon 6970. This makes the clips look a lot nicer. The other one is I have changed the quality of recording from 1080p to 480p. I still use the 1080p camera for videos, but my screen recorder in which I make tutorials and other videos with only records in 480p. Thanks for your quick reply by the way.
  • OK, so if you have changed the resolution, perhaps some other aspects of the format of your videos has changes as well? What format and codec does your screen recorder use? If you create a project and only import video from your camera, does HitFilm crash out? Then try creating a project and only importing footage from your screen recorder? Does HitFilm crash? Maybe we can determine whether it is one video source or the other that the problem is related to.
    Also, can you please go to this page to make sure you have the latest drivers for your GPU: http://support.amd.com/us/gpudownload/Pages/index.aspx
  • Screen recorders often use their own proprietary codecs, so that could be the source of the problem.
  • Please help me. I use Hitfilm 3 Express. I have been trying to use a greenscreen, but at a certain point the program crashes without saving all of my work. What can I do?

  • What is the certain point that the crash occurs? What are the specs of your machine? 

    OS:
    CPU:
    Graphics Card:
    RAM:

  • edited February 2016

    Why does Hitfilm 3 Express KEEP CCRRAASSHHIINNGG!!

  • HI! I used Hitfilm 3 and it worked fine but ever since I upgraded to Hitfilm 4, it would crash when I import a clip, move the scrolling bar or just about anything else, but only when using a bigger clip of about an hour or so. It can't be the size of the clip because I used the same types and sizes of clips in Hitfilm 3 and it worked fine then. I am not sure what my Graphics Card, GPU or OS is but I have about 32 Ram and I am running Windows 10. And I don't believe that any changes have been made to my computer. I am about to do a lot of projects all a few ours long so help would be very appreciated! Thx a lot for all your great help and tutorials about the program.

  • I just downloaded Hitfilm and whenever I try to opwn a new project, it crashes after a 12th of a minute!

  • It's been doing the same thing on my laptop as well. Sometimes it doesn't crash, but it will lag every time I try to edit, guarenteed. I find that it lags more when I use longer clips? I've been trying to edit out clips from a video that's 4 hours long, and it just keeps crashing without saving... (the final project will be more like 4 or 5 minutes long, so I really hope it won't crash as much towards the end of the editing process)

    I haven't changed the type of video files that I've been using either. I always use mp4s.

  • @ColourlessGreenIdeas - If you haven't already watched this video, I strongly recommend it:

    https://youtu.be/Yqhl0mRuTng

    BTW, if your source video is 4 hours long, that may be part of the problem.  Also compare your system specs against those recommended by HitFilm.

  • Triem23Triem23 Moderator

    Split your source video into smaller segments. Asking any NLE to work with a single 4-hour video is insane. Trust me, that's just an ugly thing to do to your poor computer. 

    Try 15 minute segments. Using Handbrake (covered partially in the video above) you can set up a Queue to split your source into segments. 

  • When i launch HitFilm Express it works normaly, but when i try to create a new project it says: We're sorry. HitFilm Express 2017 encountered a problem and has to exit.

    My question is: how can i fix this problem, and is it possible anyway.

  • Triem23Triem23 Moderator

    @Gish what is your CPU, GPU, OS, RAM and storage? Are your GPU drivers current? What Antivirus are you running? Is it a Dell or Alienware? 

  • edited November 4

    @Triem23 | CPU: Intel Core I5  | GPU: Radeon Graphics HD 6550m 1gb | OS: Windows 7 | RAM: 4GB DDR3 | Antivirus: ESET NOD32 | Acer

    It's laptop by the way, i don't know if it change something.

  • edited November 6

    I'm having also problems with the stability of Hitfilm Express 2017.

    I'm a teacher and i use it in my classes, where i have it installed in 31 computers with the same hardware ( i5; 4Gb Ram; 250 Gb SSD; Intel Graphic card; win 10 education)

    All the computers have exactly the same software installed and the problem is that Hitfilm works normal on some computers and it lags to much in others. In these, when Hitfilm starts, it takes too long to pass the File-New option and it lags a lot when editing, making it unusable. I installed the most recent intel drivers, disabled antivirus, disabled win10 services that could slow memory and HD access but nothing seems to make it stable because sometimes it works and other times it lags.

    Can anyone give me some extra tips of how to solve this ?

Sign in to comment