Selected combo-box item sometimes not in sync

Hi.
I've noticed - specifically by the layer-comboxboxes, that a selected item sometimes isn't stored. Example:
I create a fire-layer and choose another layer under "Flammable Region -> Layer". This layer will be taken, but the combobox still displays "None".
Regards,
Marc

Comments

  • edited July 2011
    You mean the box on the timeline indicating the parenting of the layer?
    This is correct; when you select a layer as the flammable region, it links the flame effect to that layer. However, the plane that the effect is placed on and the effect itself are separate things, and if you wish to parent the plane to another layer, you would do so using that box on the timeline.
    This way, you could control the shape of the flame effect by setting another layer as a flammable region, then parent the entire layer (the Plane) to another layer if you wanted to place the entire effect into the window of a passing car or something. Totally random example, I know, but hopefully you see what I mean.
  • edited July 2011
    Hi.
    No, I think it's a bug: I choose an item from that combobox (layer) and release the mouse button. The layer is choosen, i.e. the viewer updates correctly, but the comboxbox still displays "none". If I do it again, the combobox display the right layer. I had to do it twice: on 1st assignment, the comboxbox lost it's selected item, on the 2nd try, it keeps my selection.
    Regards,
    Marc
  • Yeah, I see what you are saying. If you try to choose from the drop-down menu while the Controls panel isn't selected, then it just selects the controls panel, and the menu doesn't update. As long as you are actually in the Controls panel when you adjust the controls, then its ok. But yeah, good catch, I'll make a note of that so the devs can take a look.
    Buy the way, when you say Comboxbox you mean the drop-down menu, correct? Technically I think a combo box combines a drop-down menu with a line-entry option where you can type in your selection.
  • Yep there is a bug here. It seems to apply only to effect layer-pickers if the control panel is not active (the data is being set but the combo box selected item doesn't update).
    Thanks for the report.
  • @Axel:
    Yep, I mean the drop-down menu. I my development enviroment, a dropdown-box can have edit- and readonly states, so it's the same 8-)
    Regards,
    Marc

Sign in to comment