3d layer problem

I'm bound to be doing something completely stupid, but heres my question if i render a 2d layer with effects it works fine same if i change that layer to 3d.
However if i want to have 3d layer say of someone with a gun and on top of that a 3d muzzle flash then when i render the video all i see is the muzzle flash and not the background video layer.
Can anyone tell me what I'm doing wrong here? In edit it shows and plays fine its only on export?

Comments

  • Could you post some screen shots of what you mean?
  • edited July 2011
    Not sure what you would like a screen shot of.
    I make a composite shot turn it into 3d. I add a 3d muzzle flash. I render but only the muzzle flash is visible.
    edited due to poor spelling
  • A screenshot of your interface, so we could see how you have the project set up, would be helpful.
    So in the Viewer you can see both the video and the effect, but when you render only the effect appears? Is this true of both the Editor and the Composite timeline?
  • edited July 2011
    [attachment=36:screenshot1.jpg]ok just taken one let me know if i need to take a shot of anything else. it comes out with just the muzzle flash only
  • Sorry. Yes to your question. it shows up fine as you can see on the timeline and in the viewer and editor. It just doesnt appear in final render. 2d effects are fine with effected added to them.
  • edited July 2011
    Hm, interesting. Thanks for the screencap, I'll take a closer look in a little bit.
    Does it render the same from both the composite shot and the Editor?
  • yes same either way I even change the order of the layers so even with the muzzle flash behind thats all that was shown on render. its as though it stays on top and doesnt blend. before the muzzle flash kicks in the video below flashes at the start for less than a second into display
  • Okay sorry for asking so many questions.
    I figured it out my video layer has to be 2d and everything else 3d. is that correct? can you not turn the video layer into 3d?
  • You should be able to make the video 3D as well, something isn't working correctly. What codec and format is that video file in?
  • well it was avcd from a sony camcorder but the it was rendered as lossless AVI with after effects cs5.
    I think there might be a problem with the virtual camera in that when I put perspective view on the camera seems to be behind the footage. But wouldnt that just display a mirrored version of the file.
    I'm really not sure what I'm doing wrong. At one point I could see the camera as a small white wireframe box with blue lines coming out of it showing its range of view (I think) but I couldnt get it back on repeat trys.

Sign in to comment